云安全日报210422:Ubuntu Linux内核发现执行任意代码漏洞,需要尽快升级

Ubuntu是一个以桌面应用为主的Linux操作系统。它是一个开放源代码的自由软件,提供了一个健壮、功能丰富的计算环境。

Ubuntu是一个以桌面应用为主的Linux操作系统。它是一个开放源代码的自由软件,提供了一个健壮、功能丰富的计算环境,既适合家庭使用又适用于商业环境。Ubuntu为全球数百个公司提供商业支持。

4月22日,Ubuntu发布了安全更新,修复了Linux内核发现的执行任意代码漏洞。以下是漏洞详情:

漏洞详情

来源:https://ubuntu.com/security/notices/USN-4916-2

1.CVE-2021-29154 严重程度:高

在某些情况下,Linux内核中用于x86的BPF JIT编译器无法正确验证分支位移的计算。本地攻击者可能会使用它来导致拒绝

服务(系统崩溃)或可能执行任意代码。

2.CVE-2021-3493 严重程度:高

Linux内核中overlayfs文件系统中的Ubuntu特定问题,在该问题中,它未正确验证关于用户名称空间的文件系统功能的应用程序。由于Ubuntu附带了一个允许非特权的overlayfs挂载的补丁,因此本地攻击者可以使用它来获得更高的特权。

受影响产品和版本

上述漏洞影响Ubuntu 20.04 LTS, Ubuntu 18.04 LTS, Ubuntu 16.04 LTS, Ubuntu 14.04 ESM

解决方案

可以通过将系统更新为以下软件包版本来解决此问题:

Ubuntu 20.04:

linux-image-5.6.0-1055-oem – 5.6.0-1055.59

linux-image-oem-20.04 – 5.6.0.1055.51

Ubuntu 18.04:

linux-image-gkeop-5.3 – 5.3.0.74.131

linux-image-gke-5.3 – 5.3.0.1043.26

linux-image-5.3.0-74-lowlatency – 5.3.0-74.70

linux-image-5.3.0-1040-raspi2 – 5.3.0-1040.42

linux-image-5.3.0-74-generic – 5.3.0-74.70

linux-image-5.3.0-1043-gke – 5.3.0-1043.46

linux-image-raspi2-hwe-18.04 – 5.3.0.1040.29

Ubuntu 16.04:

linux-image-4.4.0-1152-raspi2 – 4.4.0-1152.163

linux-image-powerpc-e500mc – 4.4.0.210.216

linux-image-4.4.0-210-generic-lpae – 4.4.0-210.242

linux-image-4.4.0-210-powerpc-smp – 4.4.0-210.242

linux-image-4.4.0-210-lowlatency – 4.4.0-210.242

linux-image-4.4.0-210-powerpc64-emb – 4.4.0-210.242

linux-image-virtual – 4.4.0.210.216

linux-image-snapdragon – 4.4.0.1156.148

linux-image-powerpc64-emb – 4.4.0.210.216

linux-image-4.4.0-1156-snapdragon – 4.4.0-1156.166

linux-image-4.4.0-210-powerpc-e500mc – 4.4.0-210.242

linux-image-4.4.0-1128-aws – 4.4.0-1128.142

linux-image-generic – 4.4.0.210.216

linux-image-4.4.0-210-powerpc64-smp – 4.4.0-210.242

linux-image-aws – 4.4.0.1128.133

linux-image-kvm – 4.4.0.1093.91

linux-image-4.4.0-1093-kvm – 4.4.0-1093.102

linux-image-raspi2 – 4.4.0.1152.152

linux-image-powerpc-smp – 4.4.0.210.216

linux-image-generic-lpae – 4.4.0.210.216

linux-image-4.4.0-210-generic – 4.4.0-210.242

linux-image-powerpc64-smp – 4.4.0.210.216

linux-image-lowlatency – 4.4.0.210.216

Ubuntu 14.04:

linux-image-powerpc-smp-lts-xenial – 4.4.0.210.183

linux-image-lowlatency-lts-xenial – 4.4.0.210.183

linux-image-4.4.0-210-lowlatency – 4.4.0-210.242~14.04.1

linux-image-4.4.0-210-powerpc-e500mc – 4.4.0-210.242~14.04.1

linux-image-4.4.0-210-powerpc64-emb – 4.4.0-210.242~14.04.1

linux-image-4.4.0-210-generic – 4.4.0-210.242~14.04.1

linux-image-powerpc-e500mc-lts-xenial – 4.4.0.210.183

linux-image-generic-lpae-lts-xenial – 4.4.0.210.183

linux-image-powerpc64-smp-lts-xenial – 4.4.0.210.183

linux-image-4.4.0-1092-aws – 4.4.0-1092.96

linux-image-powerpc64-emb-lts-xenial – 4.4.0.210.183

linux-image-4.4.0-210-powerpc-smp – 4.4.0-210.242~14.04.1

linux-image-aws – 4.4.0.1092.89

linux-image-generic-lts-xenial – 4.4.0.210.183

linux-image-4.4.0-210-generic-lpae – 4.4.0-210.242~14.04.1

linux-image-4.4.0-210-powerpc64-smp – 4.4.0-210.242~14.04.1

linux-image-virtual-lts-xenial – 4.4.0.210.183

查看更多漏洞信息 以及升级请访问官网:

https://ubuntu.com/security/cve

为TA充电
共{{data.count}}人
人已赞赏
云计算

特斯拉回应西安女车主维权:发生碰撞时未达气囊气帘展开阈值

2021-4-22 14:49:06

云计算

云计算核心技术Docker教程:Docker配置网络概述

2021-4-22 17:54:43

0 条回复 A文章作者 M管理员
    暂无讨论,说说你的看法吧
个人中心
购物车
优惠劵
今日签到
有新私信 私信列表
搜索